Unable to download reports
Incident Report for Kayzen
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 14:00 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 19, 2024 - 11:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2024 - 11:23 UTC
Identified
We have identified a technical glitch that is preventing users from downloading their reports as intended. Our technical team is actively investigating the root cause of this issue and is working diligently to implement a solution as swiftly as possible.
Please reach out to us via chat widget if there are any questions
Posted Apr 19, 2024 - 11:04 UTC
This incident affected: Kayzen UI.