Reporting Delay

Incident Report for Kayzen

Update

We're continuing to work on the ongoing incident affecting reporting.The processing lag is gradually decreasing, but full recovery is taking longer than initially anticipated. We will keep you posted on progress.
Posted Sep 03, 2026 - 14:52 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2026 - 09:55 UTC

Identified

Due to a technical issue, we are facing delay in reporting since 05:00 UTC, 3 Sep, 2026.
The delay is only for the following metrics wins, impressions, clicks and media spends data.
We are working on processing this data.
Note that this is a reporting issue and bidding was not impacted.
Requesting your patience on this. If you have any questions, please reach out to us via chat widget in the UI.
Posted Sep 03, 2026 - 06:27 UTC
This incident affects: Reporting and Data.