Bidding Impacted - Singapore DC

Incident Report for Kayzen

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 12:03 UTC

Identified

We wanted to inform you about a technical issue that we are experiencing from 07:15 UTC, 22nd July 2025 with our Singapore Datacenter. Due to which ad serving primarily across APAC region is impacted. We will keep you posted on further updates.

Please reach out to us via chat widget in case of any queries.
Posted Jul 22, 2025 - 07:23 UTC
This incident affected: Bidding.