Lag in audience processing

Incident Report for Kayzen

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 06:08 UTC

Update

Incident Update: We continue to observe a lag in audience processing and are actively working on resolving the issue. At this time, audience data has been successfully processed up to 29th Nov, 06:30 AM UTC, and we are working on processing the remaining backlog.
Please note that any new audiences created, or changes made to existing audiences, may take additional time to process until the lag is fully cleared.
We will share another update as soon as we make further progress.
Posted Dec 01, 2025 - 08:12 UTC

Update

We are continuing to work on a fix for this issue. Resolution is taking longer than initially expected, but we are working toward complete recovery as quickly as possible. The tentative ETA for full recovery is an additional 24 hours.
We will keep you posted as we have more updates.
Posted Nov 28, 2025 - 09:16 UTC

Identified

Due to a technical issue, we are currently experiencing a lag in audience processing. As a result, there may be delays in processing new audiences and updates to existing audiences. Our team is actively working to resolve the issue, and full recovery may take up to 24 hours.
Please note that this does not impact bidding or campaign delivery. Campaigns will continue to serve using the audience data that was successfully processed prior to the lag.
We appreciate your patience and understanding. Please feel free to reach out if you have any questions.
Posted Nov 27, 2025 - 07:09 UTC
This incident affected: Audiences.