Bidding Impacted - Singapore DC

Incident Report for Kayzen

Resolved

This incident has been resolved as of 06:08 UTC.
Posted Feb 05, 2026 - 07:07 UTC

Identified

We wanted to inform you about a technical issue that we are experiencing from 04:45 UTC, 5th Feb 2026 with our Singapore Datacenter. Due to which ad serving primarily across APAC region is impacted. We will keep you posted on further updates.
Posted Feb 05, 2026 - 05:21 UTC
This incident affected: Bidding.