Bidding Impacted & reporting delays

Incident Report for Kayzen

Resolved

This incident has been resolved; reporting data is now up to date across all metrics.
Posted Aug 22, 2025 - 13:37 UTC

Update

The reporting lag has cleared; we’re rerunning the relevant pipelines now, so data may fluctuate slightly during this process, and we’ll confirm once all metrics are fully up to date.
Posted Aug 22, 2025 - 12:25 UTC

Update

Up to date: Bids, installs, and post-install events are now current in reporting.
Still lagging: Wins, impressions, clicks, video events, and spend metrics remain delayed.

ETA: ~2 hours to clear the backlog and backfill remaining metrics.
Posted Aug 22, 2025 - 10:36 UTC

Update

The bidding issue has been resolved and ad delivery is back to normal. You may still see reporting delays while our systems finish processing the backlog.

Current status:
Delivery: Normal. Campaigns are bidding and serving as expected.
Reporting: Dashboards, exports, and APIs may show delayed or partial data for activity since 14:10 UTC on 21 Aug 2025.
No data loss is expected—metrics will backfill as processing catches up.
Temporary discrepancies between delivery and reporting are possible until backfill is complete.
If you have questions, please reach out via the in-product chat.
Posted Aug 22, 2025 - 08:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 21, 2025 - 16:44 UTC

Identified

We’re investigating a service issue that started at 14:10 UTC on 21 Aug 2025 affecting delivery and reporting.

What’s impacted

- EU region: Bidding stopped as of 14:10 UTC. Campaigns targeting EU regions may be impacted.
- Reporting lag: Dashboards, exports, and APIs may show delayed or partial data. Metrics will backfill once processing catches up.

We’ll share further updates in this thread.
For any questions, please reach out via the in-product chat widget.
Posted Aug 21, 2025 - 14:41 UTC
This incident affected: Bidding and Reporting and Data.